PRIOn Logo

CVE-2024-6309 Cross site request forgery (csrf)

Routine
Remediate Within 6 Months

CVE Information

Original CVE data

Published:
Updated:

The Attachment File Icons (AF Icons) plugin for WordPress is vulnerable to Cross-Site Request Forgery to Arbitrary File Upload in versions up to, and including, 1.3. This is due to missing nonce validation in the 'afi_overview' function and missing file type validation in the 'upload_icons' function. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

CWE:
CVSS v2-
CVSS v38.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
https://www.wordfence.com/threat-intel/vulnerabilities/id/7e3fd472-c8ea-42dc-93df-872361ec97f3?source=cve
https://plugins.trac.wordpress.org/browser/attachment-file-icons/tags/1.3/attachment-file-icons.php
https://plugins.trac.wordpress.org/browser/attachment-file-icons/tags/1.3/attachment-file-icons.php
Affected Vendors

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Cross site request forgery (csrf)

CVSS Scores as calculated by PRIOnengine
CVSS v26.8
AV:N/AC:M/AU:N/C:P/I:P/A:P
CVSS v38.8
AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
MITRE CWE Top 25

-

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1608 - Stage Capabilities
T1587.004 - Develop Capabilities (Exploits)
T1566.002 - Phishing (Spearphishing Link)
T1566 - Phishing
T1565 - Data Manipulation
T1505.003 - Server Software Component (Web Shell)
T1499.004 - Endpoint Denial of Service (Application or System Exploitation)
T1210 - Exploitation of Remote Services
T1204.001 - User Execution (Malicious Link)
T1203 - Exploitation for Client Execution
T1119 - Automated Collection
T1059 - Command and Scripting Interpreter

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.9 - Cross Site Request Forgery

Web Application Security Frameworks

Applicable if the issue likely affects a web application

WASC-9 - Cross Site Request Forgery