PRIOn Logo

CVE-2024-5225 Sql injection

Routine
Remediate Within 6 Months

CVE Information

Original CVE data

Published:
Updated:

An SQL Injection vulnerability exists in the berriai/litellm repository, specifically within the `/global/spend/logs` endpoint. The vulnerability arises due to improper neutralization of special elements used in an SQL command. The affected code constructs an SQL query by concatenating an unvalidated `api_key` parameter directly into the query, making it susceptible to SQL Injection if the `api_key` contains malicious data. This issue affects the latest version of the repository. Successful exploitation of this vulnerability could lead to unauthorized access, data manipulation, exposure of confidential information, and denial of service (DoS).

CWE: CWE-89
CVSS v2-
CVSS v3-
References
https://huntr.com/bounties/491e4884-0306-4cd4-8fe2-9a19de33bf5c
Affected Vendors

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Sql injection

CVSS Scores as calculated by PRIOnengine
CVSS v27.5
AV:N/AC:L/AU:N/C:P/I:P/A:P
CVSS v39.1
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
MITRE CWE Top 25

Vulnerability weakness type is in the top 25 CWEs according to MITRE. View Mitre Top 25 CWEs

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1565 - Data Manipulation
T1499 - Endpoint Denial of Service
T1498 - Network Denial of Service
T1485 - Data Destruction
T1203 - Exploitation for Client Execution
T1201 - Password Policy Discovery
T1190 - Exploit Public-Facing Application
T1119 - Automated Collection
T1059 - Command and Scripting Interpreter
T1020 - Automated Exfiltration

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.5 - Improper Error Handling
PCI DSS v3.2.1-6.5.1 - Injection Flaws

Web Application Security Frameworks

Applicable if the issue likely affects a web application

WASC-19 - SQL Injection