PRIOn Logo

CVE-2024-34355 Design/Logic Flaw

Routine
Remediate Within 6 Months

CVE Information

Original CVE data

Published:
Updated:

TYPO3 is an enterprise content management system. Starting in version 13.0.0 and prior to version 13.1.1, the history backend module is vulnerable to HTML injection. Although Content-Security-Policy headers effectively prevent JavaScript execution, adversaries can still inject malicious HTML markup. Exploiting this vulnerability requires a valid backend user account. TYPO3 version 13.1.1 fixes the problem described.

CWE:
CVSS v2-
CVSS v3-
References
https://github.com/TYPO3/typo3/security/advisories/GHSA-xjwx-78x7-q6jc
https://github.com/TYPO3/typo3/commit/56afa304ba8b5ad302e15df5def71bcc8d820375
https://typo3.org/security/advisory/typo3-core-sa-2024-007
Affected Vendors

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Design/Logic Flaw

CVSS Scores as calculated by PRIOnengine
CVSS v23.5
AV:N/AC:M/AU:S/C:N/I:P/A:N
CVSS v35.4
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
MITRE CWE Top 25

-

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1499.004 - Endpoint Denial of Service (Application or System Exploitation)
T1190 - Exploit Public-Facing Application
T1083 - File and Directory Discovery
T1059 - Command and Scripting Interpreter
T1005 - Data from Local System

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.1 - Injection Flaws

Web Application Security Frameworks

Applicable if the issue likely affects a web application

WASC-8 - Cross Site Scripting