PRIOn Logo

CVE-2024-27622 Remote code execution

Routine
Remediate Within 6 Months

CVE Information

Original CVE data

Published:
Updated:

A remote code execution vulnerability has been identified in the User Defined Tags module of CMS Made Simple version 2.2.19. This vulnerability arises from inadequate sanitization of user-supplied input in the 'Code' section of the module. As a result, authenticated users with administrative privileges can inject and execute arbitrary PHP code.

CWE:
CVSS v2-
CVSS v3-
References
https://github.com/capture0x/CMSMadeSimple/
https://packetstormsecurity.com/files/177241/CMS-Made-Simple-2.2.19-Remote-Code-Execution.html
Affected Vendors

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Remote code execution

CVSS Scores as calculated by PRIOnengine
CVSS v26.5
AV:N/AC:L/AU:S/C:P/I:P/A:P
CVSS v37.2
AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
MITRE CWE Top 25

-

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1499.004 - Endpoint Denial of Service (Application or System Exploitation)
T1203 - Exploitation for Client Execution
T1190 - Exploit Public-Facing Application
T1059 - Command and Scripting Interpreter

Compliance Impact

How the submited vulnerability affects compliance

-

Web Application Security Frameworks

Applicable if the issue likely affects a web application

-