PRIOn Logo

CVE-2024-1351 Input validation

Routine
Remediate Within 6 Months

CVE Information

Original CVE data

Published:
Updated:

Under certain configurations of --tlsCAFile and tls.CAFile, MongoDB Server may skip peer certificate validation which may result in untrusted connections to succeed. This may effectively reduce the security guarantees provided by TLS and open connections that should have been closed due to failing certificate validation. This issue affects MongoDB Server v7.0 versions prior to and including 7.0.5, MongoDB Server v6.0 versions prior to and including 6.0.13, MongoDB Server v5.0 versions prior to and including 5.0.24 and MongoDB Server v4.4 versions prior to and including 4.4.28. Required Configuration : A server process will allow incoming connections to skip peer certificate validation if the server process was started with TLS enabled (net.tls.mode set to allowTLS, preferTLS, or requireTLS) and without a net.tls.CAFile configured.

CWE:
CVSS v2-
CVSS v3-
References
https://jira.mongodb.org/browse/SERVER-72839
https://www.mongodb.com/docs/v5.0/release-notes/5.0/
https://www.mongodb.com/docs/v6.0/release-notes/6.0/
https://www.mongodb.com/docs/manual/release-notes/7.0/
https://www.mongodb.com/docs/manual/release-notes/4.4/
https://security.netapp.com/advisory/ntap-20240524-0010/
Affected Vendors

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Input validation

CVSS Scores as calculated by PRIOnengine
CVSS v27.5
AV:N/AC:L/AU:N/C:P/I:P/A:P
CVSS v39.1
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
MITRE CWE Top 25

-

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

-

Compliance Impact

How the submited vulnerability affects compliance

-

Web Application Security Frameworks

Applicable if the issue likely affects a web application

-