PRIOn Logo

CVE-2023-6968 Cross site request forgery (csrf)

Routine
Remediate Within 6 Months

CVE Information

Original CVE data

Published:
Updated:

The The Moneytizer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 9.5.20. This is due to missing or incorrect nonce validation on multiple AJAX functions. This makes it possible for unauthenticated attackers to to update and retrieve billing and bank details, update and reset the plugin's settings, and update languages as well as other lower-severity actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

CWE:
CVSS v2-
CVSS v38.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
https://www.wordfence.com/threat-intel/vulnerabilities/id/14351561-bd31-4aaa-931a-e72917458013?source=cve
https://wordpress.org/plugins/the-moneytizer/
Affected Vendors

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Cross site request forgery (csrf)

CVSS Scores as calculated by PRIOnengine
CVSS v24.3
AV:N/AC:M/AU:N/C:N/I:P/A:N
CVSS v34.3
AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
MITRE CWE Top 25

-

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1566.002 - Phishing (Spearphishing Link)
T1566 - Phishing
T1565 - Data Manipulation
T1204.001 - User Execution (Malicious Link)
T1119 - Automated Collection

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.9 - Cross Site Request Forgery

Web Application Security Frameworks

Applicable if the issue likely affects a web application

WASC-9 - Cross Site Request Forgery