PRIOn Logo

CVE-2023-5424 Input validation

Routine
Remediate Within 6 Months

CVE Information

Original CVE data

Published:
Updated:

The WS Form LITE plugin for WordPress is vulnerable to CSV Injection in versions up to, and including, 1.9.217. This allows unauthenticated attackers to embed untrusted input into exported CSV files, which can result in code execution when these files are downloaded and opened on a local system with a vulnerable configuration.

CVSS v2-
CVSS v38.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
https://www.wordfence.com/threat-intel/vulnerabilities/id/38ccaa81-77ec-46f2-9bec-d74fa2e093f3?source=cve
https://wsform.com/changelog/?utm_source=wp_plugins&utm_medium=readme
https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3098265%40ws-form&new=3098265%40ws-form&sfp_email=&sfph_mail=
Affected Vendors

Westguardsolutions - (1)

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Input validation

CVSS Scores as calculated by PRIOnengine
CVSS v27.5
AV:N/AC:L/AU:N/C:P/I:P/A:P
CVSS v38.8
AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
MITRE CWE Top 25

-

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1499.004 - Endpoint Denial of Service (Application or System Exploitation)
T1203 - Exploitation for Client Execution
T1190 - Exploit Public-Facing Application
T1083 - File and Directory Discovery
T1059 - Command and Scripting Interpreter
T1005 - Data from Local System

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.1 - Injection Flaws

Web Application Security Frameworks

Applicable if the issue likely affects a web application

-