PRIOn Logo

CVE-2023-50026 Sql injection

Significant
Remediate Within one Month

CVE Information

Original CVE data

Published:
Updated:

SQL injection vulnerability in Presta Monster "Multi Accessories Pro" (hsmultiaccessoriespro) module for PrestaShop versions 5.1.1 and before, allows remote attackers to escalate privileges and obtain sensitive information via the method HsAccessoriesGroupProductAbstract::getAccessoriesByIdProducts().

CWE: CWE-89
CVSS v2-
CVSS v39.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
https://security.friendsofpresta.org/modules/2024/02/08/hsmultiaccessoriespro.html
Affected Vendors

Prestamonster - (1)

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Sql injection

CVSS Scores as calculated by PRIOnengine
CVSS v27.5
AV:N/AC:L/AU:N/C:P/I:P/A:P
CVSS v39.8
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
MITRE CWE Top 25

Vulnerability weakness type is in the top 25 CWEs according to MITRE. View Mitre Top 25 CWEs

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1591 - Gather Victim Org Information
T1590 - Gather Victim Network Information
T1589.001 - Gather Victim Identity Information (Credentials)
T1565 - Data Manipulation
T1552 - Unsecured Credentials
T1529 - System Shutdown/Reboot
T1499.004 - Endpoint Denial of Service (Application or System Exploitation)
T1485 - Data Destruction
T1203 - Exploitation for Client Execution
T1201 - Password Policy Discovery
T1190 - Exploit Public-Facing Application
T1119 - Automated Collection
T1082 - System Information Discovery
T1068 - Exploitation for Privilege Escalation
T1059 - Command and Scripting Interpreter
T1020 - Automated Exfiltration
T1003 - OS Credential Dumping

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.5 - Improper Error Handling
PCI DSS v3.2.1-6.5.1 - Injection Flaws

Web Application Security Frameworks

Applicable if the issue likely affects a web application

WASC-19 - SQL Injection