PRIOn Logo

CVE-2022-39227 Authentication flaw

Significant
Remediate Within one Month

CVE Information

Original CVE data

Published:
Updated:

python-jwt is a module for generating and verifying JSON Web Tokens. Versions prior to 3.3.4 are subject to Authentication Bypass by Spoofing, resulting in identity spoofing, session hijacking or authentication bypass. An attacker who obtains a JWT can arbitrarily forge its contents without knowing the secret key. Depending on the application, this may for example enable the attacker to spoof other user's identities, hijack their sessions, or bypass authentication. Users should upgrade to version 3.3.4. There are no known workarounds.

CWE: CWE-290
CVSS v2-
CVSS v39.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
References
https://github.com/davedoesdev/python-jwt/commit/88ad9e67c53aa5f7c43ec4aa52ed34b7930068c9
https://github.com/davedoesdev/python-jwt/security/advisories/GHSA-5p8v-58qm-c7fp
https://github.com/pypa/advisory-database/blob/main/vulns/python-jwt/PYSEC-2022-259.yaml
https://www.vicarius.io/vsociety/posts/authentication-bypass-in-python-jwt
Affected Vendors

Python-jwt Project - (1)

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Authentication flaw

CVSS Scores as calculated by PRIOnengine
CVSS v26.8
AV:N/AC:M/AU:N/C:P/I:P/A:P
CVSS v39.1
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
MITRE CWE Top 25

-

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1589.001 - Gather Victim Identity Information (Credentials)
T1190 - Exploit Public-Facing Application
T1185 - Browser Session Hijacking
T1133 - External Remote Services
T1036 - Masquerading

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.10 - Broken Authentication & Session Management

Web Application Security Frameworks

Applicable if the issue likely affects a web application

WASC-18 - Credential and Session Prediction