PRIOn Logo

CVE-2021-45007 Cross site request forgery (csrf)

Routine
Remediate Within 6 Months

CVE Information

Original CVE data

Published:
Updated:

Plesk 18.0.37 is affected by a Cross Site Request Forgery (CSRF) vulnerability that allows an attacker to insert data on the user and admin panel. NOTE: the vendor states that this is only a site-specific problem on websites of one or more Plesk users

CWE: CWE-352
CVSS v24.3
AV:N/AC:M/AU:N/C:N/I:P/A:N
CVSS v36.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
References
https://github.com/AS4mir/CVE-2021-45007/blob/main/README.md
Affected Vendors

Plesk - (1)

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Cross site request forgery (csrf)

CVSS Scores as calculated by PRIOnengine
CVSS v25.8
AV:N/AC:M/AU:N/C:N/I:P/A:P
CVSS v37.1
AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
MITRE CWE Top 25

Vulnerability weakness type is in the top 25 CWEs according to MITRE. View Mitre Top 25 CWEs

Exploits

No exploit code is reported to exist.

Active Exploitation

Vulnerability is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1566.002 - Phishing (Spearphishing Link)
T1566 - Phishing
T1565 - Data Manipulation
T1204.001 - User Execution (Malicious Link)
T1190 - Exploit Public-Facing Application
T1119 - Automated Collection

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.9 - Cross Site Request Forgery

Web Application Security Frameworks

Applicable if the issue likely affects a web application

WASC-9 - Cross Site Request Forgery