PRIOn Logo

CVE-2021-21551 Improper access control

Immediate
Remediate Within 48 Hours

CVE Information

Original CVE data

Published:
Updated:

Dell dbutil_2_3.sys driver contains an insufficient access control vulnerability which may lead to escalation of privileges, denial of service, or information disclosure. Local authenticated user access is required.

CWE:
CVSS v24.6
AV:L/AC:L/AU:N/C:P/I:P/A:P
CVSS v37.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
https://www.dell.com/support/kbdoc/en-us/000186019/dsa-2021-088-dell-client-platform-security-update-for-dell-driver-insufficient-access-control-vulnerability
http://packetstormsecurity.com/files/162604/Dell-DBUtil_2_3.sys-IOCTL-Memory-Read-Write.html
http://packetstormsecurity.com/files/162739/DELL-dbutil_2_3.sys-2.3-Arbitrary-Write-Privilege-Escalation.html
Affected Vendors

Dell - (1)

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Improper access control

CVSS Scores as calculated by PRIOnengine
CVSS v24.6
AV:L/AC:L/AU:N/C:P/I:P/A:P
CVSS v37.8
AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
MITRE CWE Top 25

-

Exploits

Exploits are available either through exploit packs, Github repos or the world wide web in general.

Active Exploitation

Vulnerability is referenced under CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

Vulnerability is mentioned or trending in social media.

Threat Actor Activity

Vulnerability is being actively exploited by threat actors during campaigns.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1591 - Gather Victim Org Information
T1590 - Gather Victim Network Information
T1589.001 - Gather Victim Identity Information (Credentials)
T1552 - Unsecured Credentials
T1499 - Endpoint Denial of Service
T1498 - Network Denial of Service
T1203 - Exploitation for Client Execution
T1082 - System Information Discovery
T1059 - Command and Scripting Interpreter
T1003 - OS Credential Dumping

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.8 - Improper Access Control
PCI DSS v3.2.1-6.5.5 - Improper Error Handling

Web Application Security Frameworks

Applicable if the issue likely affects a web application

-