PRIOn Logo

CVE-2016-7201 Memory corruption

Urgent
Remediate Within one Week

CVE Information

Original CVE data

Published:
Updated:

The Chakra JavaScript scripting engine in Microsoft Edge allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, aka "Scripting Engine Memory Corruption Vulnerability," a different vulnerability than CVE-2016-7200, CVE-2016-7202, CVE-2016-7203, CVE-2016-7208, CVE-2016-7240, CVE-2016-7242, and CVE-2016-7243.

CWE: CWE-843
CVSS v27.6
AV:N/AC:H/AU:N/C:C/I:C/A:C
CVSS v38.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
http://www.securityfocus.com/bid/94038
https://github.com/theori-io/chakra-2016-11
http://packetstormsecurity.com/files/140382/Microsoft-Edge-chakra.dll-Information-Leak-Type-Confusion.html
https://www.exploit-db.com/exploits/40990/
http://www.securitytracker.com/id/1037245
https://www.exploit-db.com/exploits/40784/
https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-129
Affected Vendors

Microsoft - (1)

Basic Analysis

Common vulnerability metrics

Vulnerabilty type as detected by PRIOnengine

Memory corruption

CVSS Scores as calculated by PRIOnengine
CVSS v27.6
AV:N/AC:H/AU:N/C:C/I:C/A:C
CVSS v37.5
AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
MITRE CWE Top 25

-

Exploits

Exploits are available either through exploit packs, Github repos or the world wide web in general.

Active Exploitation

Vulnerability is referenced under CISA's Known Exploited Vulnerabilities (KEV) catalog. See the KEV Catalog

Social Network Activity

-

Threat Actor Activity

No sightings of the vulnerability within threat reports.

Cybersecurity Frameworks

How the vulnerability maps against various cybersecurity frameworks

T1566 - Phishing
T1499.004 - Endpoint Denial of Service (Application or System Exploitation)
T1499 - Endpoint Denial of Service
T1498 - Network Denial of Service
T1203 - Exploitation for Client Execution
T1189 - Drive-by Compromise
T1059 - Command and Scripting Interpreter

Compliance Impact

How the submited vulnerability affects compliance

PCI DSS v3.2.1-6.5.5 - Improper Error Handling

Web Application Security Frameworks

Applicable if the issue likely affects a web application

-